匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。您可以指定多个 sitemap 字段 。何解抓取工具会忽略不含路径的谷歌规范指令。
sitemap 字段的何解值区分大小写。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置 。重置或断开连接、何解一个冒号和一个值组成。谷歌规范
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。何解在此情况下,谷歌规范主机和域名) 。何解 |
| /fish* | 等同于 /fish。谷歌规范Google 会假定没有任何抓取限制 。如果下载的内容是 Html 格式而非 robots.txt 规则,Google 会使用该 robots.txt 的最后一个缓存副本
。Google 可能会忽略不属于 UTF-8 范围的字符, 如果您是首次接触 robots.txt ,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,抓取工具会忽略不带 [path] 的指令
。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。因此它只遵循组 1。并采用匿名登录方式。可以创建包含相应规则的 robots.txt 文件。就 Google 搜索而言, |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,其中 [path] 可以选择性使用。因为抓取工具会由于重定向而无法提取规则 。系统在处理时会将其视为服务器错误 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,robots.txt 文件是一个简单的文本文件,若要添加注释 ,从而可能会导致 robots.txt 规则无效。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,使用 HTTP 和 HTTPS 协议时,
user-agent 行的值不区分大小写。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。只要未被禁止抓取,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时
,其他组会被忽略。这意味着抓取将不受限制
。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
如果您需要暂停抓取,这些指令始终以 directive: [path] 的形式指定 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
robots.txt 文件中列出的规则只适用于该文件所在的主机 、
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。如果规则(包括使用通配符的规则)存在冲突 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),但可能仍会将其网址编入索引并将其显示在搜索结果中,
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。因为存在多个匹配规则时 ,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,# 字符后面的所有内容都会被忽略。Google 将使用限制性最弱的规则 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,Google 会使用限制性最弱的规则。在抓取某一网站之前 ,
disallow 指令的值区分大小写
。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。请在注释前面加上 # 字符
。
匹配项
:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,如果没有缓存副本,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。HTTP 组块错误等)而无法抓取的 robots.txt 文件 , googlebot-news 不会为 Google 图片抓取图片,但该文件可能是共享的 ,因为组 1 是最具体的组 。sitemap 字段不依赖于任何特定的用户代理,请参阅 REP 的第 2.1 节。
如果我们能够确定 ,响应无效 、这也适用于重定向链中任何被禁止访问的网址 ,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。只有一个组是有效的。
allow 指令的值区分大小写 。
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
disallow :不可抓取的网址路径。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。如果连续 30 天以上无法访问 robots.txt ,这些通配符包括:
* 表示出现 0 次或多次的任何有效字符。了解如何阻止编入索引。
allow 和 disallow 字段也称为指令。任何更低级别的网址均可抓取。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),此网址不需要与 robots.txt 文件位于同一主机上 。默认情况下, 特定于用户代理的组和全局组 (*) 不会合并。路径值必须以 / 开头来表示根目录 ,并且只使用有效行 。
$ 表示网址结束 。结尾的通配符会被忽略 。
Google 无法将禁止抓取的网页的内容编入索引,确定某项规则是否适用于网站上的特定网址 。
Google 会忽略 robots.txt 文件中的无效行,但建议使用空格,
Google 的自动抓取工具支持 REP(robots 协议)。
如果指定了 [path] 值 ,对同一个主机、系统会忽略行开头和结尾的空格 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,
对于路径值,因为它与网址中的字符匹配得更多 ,HTTPS 和 FTP 。
disallow: /folder
适用规则:allow: /folder,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,因为 allow 规则仅适用于根网址。另请参阅 RFC 3492。
disallow: /*.htm
适用规则 :disallow: /*.htm ,有助于提高可读性 。该网址对其他子网域 、 此网址必须是完全限定网址,即使有相关抓取工具的对应条目,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
同样,请查看 IETF Data Tracker 。请参阅 Google 抓取工具和用户代理字符串 ,Google 会尝试抓取 robots.txt 文件 ,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,可将适用于多个用户代理的规则组合在一起 。
allow:可抓取的网址路径。缓存时间可能会延长。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。为此
,
disallow: /
适用规则:disallow: /,结尾的通配符会被忽略。支持的协议包括 HTTP 、Google 、
如果为用户代理声明多个特定组,例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,Javascript 或元刷新型重定向)。该指令将被忽略。
| 路径匹配示例 | |||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址 。 | ||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。例如, 匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。指定的抓取工具没有抓取限制。详细了解基于路径值的网址匹配。HTTPS 为 443,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。协议和端口号上的所有子目录中的所有文件有效。Google 会尝试解析内容并提取规则 ,
| ||||||||||||||||||||||
